import Foundation
let pattern = #"^(?:http:\/\/|https:\/\/)?(?:www\.)?(?:imdb.com\/title\/)?(tt[0-9]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
http://www.imdb.com/title/tt2488496/?ref_=nv_sr_1
http://www.imdb.com/title/tt2488496/
https://www.imdb.com/title/tt2488496
imdb.com/title/tt2488496
tt2488496
imdb.com/title/season2488496
http://www.imdb.com/title/tt2488496
http://www.imdb.com/news/ni59315274
www.imdb.com/title/tt2488496/?ref_=nv_sr_1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)