use strict;
my $str = '[quote=144][quote=142]fddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddd MOBİLE UYGUN OLMAYAN YAZI dsssssssssssssssssssssss
what has changed?
[/quote]
Burayla ne alakası var URL kısaltıcının parçası o.[/quote]
deneme';
my $regex = qr~\[(code|php|html)](.*?)\[/\\1](*SKIP)(*F)|\[quote(\]|(=.*?)\]|(\s.*?)\])(.*?)\[\/quote\]~sip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}