const regex = /Debug.*?endmsg(*SKIP)(*F)|restart-required/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Debug.*?endmsg(*SKIP)(*F)|restart-required', '')
const str = `Debug: testing message with no restart-required.endmsg.Warn:garbagestuff.Debug: another message.endmsg.Warn:moregarbage.Debug: this testing message has restart-required.endmsg.Error:server 404 not found.Critical restart-required. Debug: blah blah restart-required.endmsg.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);