using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(#[a-z]+\\n)|\\n(?!#)";
string substitution = @"\1";
string input = @"bla1;\nbla2;\nbla3;\n#endif\nbla4;";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}