#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?<=.com\\)[^\\]*(?=\\))"
Local $sString = "SERVERNAME2018-03-08 18:40:28 File: "x:\_default\app.address.com\MedSoftware\.data\BackEnd.Technical.Dictionaries.Service-180308182311\Web.config", Name: "dictionaries_data_product", CS: "###connectionStrings.dictionariesdataproduct.connectionString" info: Format of the initialization string does not conform to specification starting at index 0. 6069" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")