re = /(?:^([sS][mM][bB]\:\/\/(?:(?:[^@\\\/]+(?:\:[^@]+@)[^@\\\/\?]+)|(?:[^\\\/?]+)))\/([^\\\/]+)(?:[\\\/]([^?\:]*))?$)/m
str = 'smb://server;user:\\pas/sw\\ord@1.1.1:56/share/d/r/r
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end