// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^([sS][mM][bB]\:\/\/(?:(?:[^@\\\/]+(?:\:[^@]+@)[^@\\\/\?]+)|(?:[^\\\/?]+)))\/([^\\\/]+)(?:[\\\/]([^?\:]*))?$)").unwrap();
let string = "smb://server;user:\\pas/sw\\ord@1.1.1:56/share/d/r/r
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}