#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?!index)[a-zA-Z]+\.js"
Local $sString = "mid [sentence] match" & @CRLF & _
"foo[bar]" & @CRLF & _
"bar[foo]bar" & @CRLF & _
"defr.js" & @CRLF & _
"drefrf.frgt" & @CRLF & _
"trg/Frefze/FerfzeFE/Frfrfr/index.js"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")