use strict;
my $str = '
<a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a>
<a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a>
<a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a>
';
my $regex = qr%<a[^>]*?~dead host~.*?</a>%ip;
my $subst = ' ';
my $result = $str =~ s%$regex%$subst%rg;
print "The result of the substitution is' $result\n";