# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/~\\/home\\/([A-Za-z_0-9-]+)$//;t' <<< "172.168.255.0:80/home/hiii
"