using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"~\/home\/([A-Za-z_0-9-]+)$";
string substitution = @"";
string input = @"172.168.255.0:80/home/hiii
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}