// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"~\/home\/([A-Za-z_0-9-]+)$").unwrap();
let string = "172.168.255.0:80/home/hiii
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}