package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\bSTDMETHOD\b(.*?)\bPURE\b`)
var str = `STDMETHOD(MyFunc)(
D2D1_SIZE_U size,
_In_opt_ CONST void *srcData,
) PURE;
STDMETHOD(MyFunc2)(
_In_opt_ CONST void *srcData2,
UINT32 pitch2,
) PURE;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}