const regex = /^(\\|\/)(bye|end)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\\\|\\\/)(bye|end)$', '')
const str = `\\bye`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);