$re = '/\"empRef\":\"(?<empRef>[^\"]*)\"/';
$str = '[{"friendlyName":"","empRef":"012/AB00000"},{"friendlyName":"","empRef":"023/AB11111"}]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);