use strict;
my $str = 'The name is Anthony is is The name is Anthony
India is my country All Indians are India is my country
Times of India Alphabet Google is the company Alphabet Google canteen
boi is oi';
my $regex = qr/(\b\w+[\w\s]+\b)(?:.*?\b\1)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}