$re = '/(?:(?:.*?\|\s?){6}.*::)(.+?)(?:(?=\.?\s?$)|(?=\s?\.?\|))/i';
$str = '[String1] | [String two is here] ||| String 3 | String-4 | String::5';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);