#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w\w\w\w$"
Local $sString = "virūpa..." & @CRLF & _
"...caká¹£us" & @CRLF & _
"dharmacaká¹£us" & @CRLF & _
"nayacaká¹£us-" & @CRLF & _
"-sūryacakṣus" & @CRLF & _
"Q di" & @CRLF & _
"? saṃgrah" & @CRLF & _
"Äsaṃgrah" & @CRLF & _
"upasaṃgrah" & @CRLF & _
"W pratisaṃgrah" & @CRLF & _
"abhisaṃgrah" & @CRLF & _
"M anusaṃgrah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")