#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(http:\/\/)?(www\.)?\w*\.(com|net|org)$"
Local $sString = "stackoverflow" & @CRLF & _
"stackoverflow.com" & @CRLF & _
"www.stackoverflow.com" & @CRLF & _
"http://www.stackoverflow.com" & @CRLF & _
"someone@stackoverflow.com" & @CRLF & _
"foo.bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")