$re = '/^(?!.*?\.).*?(#.*\w*[a-zA-Z_]+\w*)/m';
$str = 'hello#music
#hello#music
hello.com#music -> no match';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;