import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\n"
+ " .?\\n+ |\n"
+ " [[:alnum:]_](?=[^[:alnum:]_\\s]) |\n"
+ " [^[:alnum:]_\\s](?=[[:alnum:]_]) |\n"
+ " [^\\S\\n](?=[\\S\\n]) |\n"
+ ")\n"
+ "(\n"
+ "(?:\n"
+ " [[:alnum:]_]+ |\n"
+ " [^[:alnum:]_\\s]+ |\n"
+ ")\n"
+ "[^\\S\\n]*\n"
+ ")";
final String string = "w asdf";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}