Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?: .?\n+ | [[:alnum:]_](?=[^[:alnum:]_\s]) | [^[:alnum:]_\s](?=[[:alnum:]_]) | [^\S\n](?=[\S\n]) | ) ( (?: [[:alnum:]_]+ | [^[:alnum:]_\s]+ | ) [^\S\n]* )
/
xX
Input 1
1
New
w asdf