re = /(?:
.?\n+ |
[[:alnum:]_](?=[^[:alnum:]_\s]) |
[^[:alnum:]_\s](?=[[:alnum:]_]) |
[^\S\n](?=[\S\n]) |
)
(
(?:
[[:alnum:]_]+ |
[^[:alnum:]_\s]+ |
)
[^\S\n]*
)/x
str = 'w asdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end