import Foundation
// WARNING: You included a flag that Swift doesn't support: X
// When this flag is set, it causes any backslash in the pattern that is followed by a letter that has no special meaning to cause an error.
// By default in Swift, a backslash followed by a letter with no special meaning will be treated as a literal.
let pattern = #"""
(?:
.?\n+ |
[[:alnum:]_](?=[^[:alnum:]_\s]) |
[^[:alnum:]_\s](?=[[:alnum:]_]) |
[^\S\n](?=[\S\n]) |
)
(
(?:
[[:alnum:]_]+ |
[^[:alnum:]_\s]+ |
)
[^\S\n]*
)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"w asdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}