using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s|\()like(\s|\))\s*\(('((\w|%|'{2})]*)')\s*\+\s?@p\d+\s*\+('%')\)";
string input = @"where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%')
a + 'b' like ('%'+@p2+'%')
concat(a,b) like ('%'+@p2+'%') or ltrim(a) like ('%'+@p2+'%')
select * from a where concat(a,b) like 'a' and c like d or ltrim(a) like ('%'+@p2+'%')";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}