# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\s|\()like(\s|\))\s*\(('((\w|%|'{2})]*)')\s*\+\s?@p\d+\s*\+('%')\)"
test_str = ("where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%')\n\n\n"
" a + 'b' like ('%'+@p2+'%')\n"
" concat(a,b) like ('%'+@p2+'%') or ltrim(a) like ('%'+@p2+'%')\n"
"select * from a where concat(a,b) like 'a' and c like d or ltrim(a) like ('%'+@p2+'%')")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.