#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z][a-z0-9]*([._-][a-z0-9]+)*$"
Local $sString = "abcde1" & @CRLF & _
"abcde" & @CRLF & _
"abc.de" & @CRLF & _
"abc.de-uu8_1" & @CRLF & _
"abc.de-uu8_12" & @CRLF & _
"abcde_" & @CRLF & _
"_abcde" & @CRLF & _
"abcde." & @CRLF & _
".abcde" & @CRLF & _
"ww_.abcde" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")