const regex = /^[a-z][a-z0-9]*([._-][a-z0-9]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z][a-z0-9]*([._-][a-z0-9]+)*$', 'gm')
const str = `abcde1
abcde
abc.de
abc.de-uu8_1
abc.de-uu8_12
abcde_
_abcde
abcde.
.abcde
ww_.abcde
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}