$re = '/^[a-z][a-z0-9]*([._-][a-z0-9]+)*$/m';
$str = 'abcde1
abcde
abc.de
abc.de-uu8_1
abc.de-uu8_12
abcde_
_abcde
abcde.
.abcde
ww_.abcde
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);