#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:)?\/\/(?:(?:www\.)?youtube\.com|youtu\.be)\/(?:(?:watch\?v=|user|v\/|embed\/))?([a-zA-Z0-9]+)"
Local $sString = "https://www.youtube.com/watch?v=fxIgkgBbpQg" & @CRLF & _
"https://youtube.com/watch?v=fxIgkgBbpQg" & @CRLF & _
"https://youtu.be/fxIgkgBbpQg" & @CRLF & _
"http://www.youtube.com/watch?v=fxIgkgBbpQg" & @CRLF & _
"http://youtube.com/watch?v=fxIgkgBbpQg" & @CRLF & _
"http://youtu.be/fxIgkgBbpQg" & @CRLF & _
"//www.youtube.com/watch?v=fxIgkgBbpQg" & @CRLF & _
"//youtube.com/watch?v=fxIgkgBbpQg" & @CRLF & _
"//youtu.be/fxIgkgBbpQg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")