const regex = /^(?:https?:)?\/\/(?:(?:www\.)?youtube\.com|youtu\.be)\/(?:(?:watch\?v=|user|v\/|embed\/))?([a-zA-Z0-9]+)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:)?\\\/\\\/(?:(?:www\\.)?youtube\\.com|youtu\\.be)\\\/(?:(?:watch\\?v=|user|v\\\/|embed\\\/))?([a-zA-Z0-9]+)', 'mg')
const str = `https://www.youtube.com/watch?v=fxIgkgBbpQg
https://youtube.com/watch?v=fxIgkgBbpQg
https://youtu.be/fxIgkgBbpQg
http://www.youtube.com/watch?v=fxIgkgBbpQg
http://youtube.com/watch?v=fxIgkgBbpQg
http://youtu.be/fxIgkgBbpQg
//www.youtube.com/watch?v=fxIgkgBbpQg
//youtube.com/watch?v=fxIgkgBbpQg
//youtu.be/fxIgkgBbpQg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}