use strict;
my $str = 'https://www.youtube.com/watch?v=fxIgkgBbpQg
https://youtube.com/watch?v=fxIgkgBbpQg
https://youtu.be/fxIgkgBbpQg
http://www.youtube.com/watch?v=fxIgkgBbpQg
http://youtube.com/watch?v=fxIgkgBbpQg
http://youtu.be/fxIgkgBbpQg
//www.youtube.com/watch?v=fxIgkgBbpQg
//youtube.com/watch?v=fxIgkgBbpQg
//youtu.be/fxIgkgBbpQg';
my $regex = qr/^(?:https?:)?\/\/(?:(?:www\.)?youtube\.com|youtu\.be)\/(?:(?:watch\?v=|user|v\/|embed\/))?([a-zA-Z0-9]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}