re = /(?i)(?:adafruit)/m
str = 'adafruit_api_key = "x-xfiu9qulytekagka60cn2ey1rrrba4"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end