# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ISA(?<data1>.*?)ESA.ISA(?<data2>.*?)ESA./data1: ${data1}\ndata2: ${data2}/g;t' <<< "ISA~this is date~ESA|ISA~this is more data~ESA|"