use strict;
my $str = 'ISA~this is date~ESA|ISA~this is more data~ESA|';
my $regex = qr/ISA(?<data1>.*?)ESA.ISA(?<data2>.*?)ESA./p;
my $subst = 'data1: ${data1}\\ndata2: ${data2}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";