const regex = new RegExp('[\\u0621-\\u064A\\u0660-\\u0669 ]+', 'g')
const str = `بطيبـةَ رسـمٌ للرسـولِ ومعهـدُ منيرٌ ، وقد تعفو الرسـومُ وتهمـد ولا تنمحي الآياتُ من دارِ حرمـةٍ بِها منبرُ الهادي الذي كانَ يصعـدُ وواضحُ آيـاتٍ، وباقـي معالـمٍ وربعٌ لهُ فيـهِ مصلـىً ومسجـدُ بِها حجراتٌ كانَ ينـزلُ وسطهـا منَ اللهِ نـورٌ يستضـاءُ، ويوقـدُ `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}