re = /\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUEST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_POST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUET\[.*\]/i
str = 'afrawefaew = $_REQUEST[\'foo\']
sfvdfvsdfv=$_REQUEST[\'foo\']
sdfvsdfv =$_REQUEST[\'barbar\']
sdfvsdfv= $_REQUEST[\'baz\']
sdfsdv == $_REQUEST[\'123sgrtrthrsh\']
$_GET[\'foo\']
$_GET[\'barbar\']
$_get[\'baz\']
$_POST[\'123sgrtrthrsh\']
$_post[\'123sgrtrthrsh\']
'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end