using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\*$)|(.*\([^\)]*$)|(^[^\(]*\))|(.*\(\).*)|(^\s*(?:and|or)\s)|((?:and|or)\s*$)";
string input = @"andftesting(sadggds) and g";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}