re = /(\bOIL CHANGE REQUEST V3\b .*\s.*)/mi
str = '<testerconfirmation title="Tester Confirmation " passedbutton="yes" timeoutresult="failed">REQUIREMENT SPECTED
After T_Checkdisplay (5 seconds), the indication OIL CHANGE REQUEST V3 must be activated according to indications characteristics during 5 seconds.
Press YES to continue.</testerconfirmation>
<testerconfirmation title="Tester Confirmation " passedbutton="yes" timeoutresult="failed">REQUIREMENT SPECTED
After T_Checkdisplay (5 seconds), the indication OIL CHANGE REQUEST V1 must be activated according to indications characteristics during 5 seconds.
Press YES to continue.</testerconfirmation>
<testerconfirmation title="Tester Confirmation " passedbutton="yes" timeoutresult="failed">REQUIREMENT SPECTED
After T_Checkdisplay (5 seconds), the indication OIL CHANGE REQUEST V2 must be activated according to indications characteristics during 5 seconds.
Press YES to continue.</testerconfirmation>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end