import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:, \\d+)*$";
final String string = "1\n"
+ "2, 3\n"
+ "6, 7, 4\n"
+ ",5\n"
+ "5 6 0\n"
+ "4,5\n\n\n"
+ "1 - ok!\n"
+ "2, 3 - ok!\n"
+ "6, 7, 4 -ok!\n"
+ ",5 - bad!\n"
+ "5 6 0 - bad!\n"
+ "4,5 - bad!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}