#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?!\s)[^\p{Arabic}\r\n]+"
Local $sString = "این یک تست جدید است" & @CRLF & _
"fine just working line English my Is?" & @CRLF & _
"does it hope I..." & @CRLF & _
"این یک جمله جدید است English in continued be to is this and..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")