$re = '/^\s*at\s*([^(]*)\.([^\.(]*)\([^:]*:(\d+).*$/';
$str = ' at sun.nio.ch.SocketDispatcher.read(SocketDispatcher.java:39)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);