#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:class).*(?<!\-)(?:[[:blank:]]|\")(button)(?:[[:blank:]]|\")"
Local $sString = "class="button"" & @CRLF & _
"class=" button"" & @CRLF & _
"class=" my-button"" & @CRLF & _
"class="mybutton"" & @CRLF & _
"class=" my button"" & @CRLF & _
"class=" my buttong"" & @CRLF & _
""button""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")