re = /(?:class).*(?<!\-)(?:[[:blank:]]|\")(button)(?:[[:blank:]]|\")/
str = 'class="button"
class=" button"
class=" my-button"
class="mybutton"
class=" my button"
class=" my buttong"
"button"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end