$re = '/J[a-z\s]+Neu/mi';
$str = 'JNeu
JJJJJJJJNeu
Jenny Neu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);