const regex = /([a-zA-Z]{3})([UJZujz])(\d{6})(\d)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]{3})([UJZujz])(\\d{6})(\\d)', '')
const str = `CAXU1234567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}