re = /(\w+)=([\d|\w]+)(?=;|\"|\Z)/
str = 'nama=john; class=6; height=170; weight=70'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end