# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<img.*\\/>)//i;t' <<< "http://www.google.com <img src=\"http://placehold.it/350x150\" />"