use strict;
my $str = 'http://www.google.com <img src="http://placehold.it/350x150" />';
my $regex = qr/(<img.*\/>)/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";