using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"h.*e.*l.*l.*o.* .*w.*o.*r.*l.*d";
string input = @"1h2e3l4l5o6 7w8o9r0l0d0";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}